Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Recently getting into wordpress plugin development, I started to investigate how to make my code backward compatible to php 4+. I've focused only on php 5.1+ for the past 5 years, so this was an ordeal.

Anyway, when looking at some plugins, one of them had this description:

IMPORTANT: This plugin is not compatible with PHP 4. If you try to install it on a host running PHP 4, you will get a parse error. WordPress is ending support for PHP 4 as of version 3.2

Is it true that wordpress is going to stop supporting php prior to php 5?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Yes, version 3.1 is the last version to support PHP 4.

For WordPress 3.2, due in the first half of 2011, we will be raising the minimum required PHP version to 5.2. Why 5.2? Because that’s what the vast majority of WordPress users are using, and it offers substantial improvements over earlier PHP 5 releases. It is also the minimum PHP version that the Drupal and Joomla projects will be supporting in their next versions, both due out this year.

Based on that announcement page, I'd actually expect 3.2 to be released a little later this year (i.e. early Q3), since 3.1 ended up a few months later than that page projected (not a knock on the dev team, FYI - just conjecture on my part).

share|improve this answer
add comment

This is true. See the announcement here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.