Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use nginx, php5-fpm and fastcgi_cache. W3TC minification seems good enough, but every include points to "minify.php?". I want to be able to keep my site up even if php and mysql server's goes down - surviving on cached (stale) versions of my pages.

Is there any way to not touch php for serving minified assets? I mean its already minified and probably gzipped, why does it need to go through .php? I am missing something?

My links look like this:

<link rel="stylesheet" type="text/css" href="http://www.domain.com.br/wp-content/plugins/w3-total-cache/pub/minify.php?file=bZBdjoMwDIQvtE6K9mV7msoEC2hDnI0daG6_odAfrXibGX-yxj5ZXShoIU8zBStaPH019hZHh4LQo_eUytNfdn9AyIAdLy3f36pSSwSXRXmiBInmkRY5yirZM_eewKGn0GGCtY6KdSK2dwTPYjsWfRbgQNBmVQ7QFrhNlYx8WUd1UtkryMBJHXe0Lbpi-R_v9dcWG_KbqzUfMXyb0-GyB2llYtYh0CuBPEJjfszZbFduX0jkMKob0L7UHw.css" media="all" />
share|improve this question

put on hold as off-topic by Pieter Goosen, G. M., Johannes Pille, bungeshea, ialocin yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – Pieter Goosen, G. M., Johannes Pille, bungeshea, ialocin
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Thanks alot. At first I had Rewrite URL structure ON and no rules on nginx side and was getting 404 errors on the assets so I disabled the option and completely forgot about it. Best regards. –  ddutra Oct 9 '13 at 20:22

1 Answer 1

up vote 0 down vote accepted

Yes. You are missing the rewrite rules that'll prettify the URLs of the minified assets.

Follow the instructions available for your setup at WordPress Dashboard > Performance (W3 Total Cache menu) > Install.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.