Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have just changed ports on MAMP from :8888 to :80 for localhost in order to setup a WordPress multisite for local development. However I have several sites with separate installations that are in my htdocs folder and previously used localhost:8888 as a root.

I did the following things in order :

  1. Opened wp-config and changed the Mysql hostname to define('DB_HOST', 'localhost');
  2. Went to the options table of the database and changed the siteurl and home.
  3. I cleared my .htaccess file
  4. Cleared my browser cache.

Still, when I am at the index for localhost I am still being redirected to localhost:8888. I'm sure other people have had this problem and yet I can't seem to find the same question.

Interestingly enough I have access to admin just not to the front end.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You need to treat this just like you would when changing domains.

The short version is:

  1. You need to change the WordPress Address and Site Address in Settings->General. You have to change both

  2. Or edit wp-config.php to alter the same values as in step #1. This one is easiest if you've already lost part of the site functionality.

  3. And alter the hard-coded addresses in the DB. I have always used Velvet Blues Update Urls for that.

The Codex has a link to a helper script and a longer 15 step process. Read through that carefully before beginning.

share|improve this answer
    
Ah, I see. Missed the WordPress address but I would have thought I could find it in the options table. Just out of curiosity where is it kept in the DB? I'll have to try that Velvet Blues update urls. Thank you once again :) –  mantis Oct 8 '13 at 13:57
    
It is in the options table. Look for siteurl and home –  s_ha_dum Oct 8 '13 at 14:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.