Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So, here's the deal.

I got one WP Multisite installed with 1 subsite. Im running the whole thing in subdomain "mode". I did the whole DNS-pointer (A *.domain.se) to the correct IP.

Now the problem, even though i created a subsite in wp-admin (lets call it foobar), when i type in foobar.domain.se i get redirected to the mainsite (domain.se). foobar.domain.se/wp-admin/ on the other hand casts a 404 error.

Is it host related or something wrong in my config? More info, host got a shared IP - might be the problem (even though I got the impression it should work anyways)? I've searched like crazy on the web, in my htaccess and for hostsettings - and it should be the correct ones.

**.htaccess**
#BEGIN WordPress  
RewriteEngine On  
RewriteBase /  
RewriteRule ^index\.php$ - [L]  

#uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]  

RewriteCond %{REQUEST_FILENAME} -f [OR]  
RewriteCond %{REQUEST_FILENAME} -d  
RewriteRule ^ - [L]  
RewriteRule . index.php [L]  
# END WordPress  

**wp-config.php**
    define('WP_ALLOW_MULTISITE', true);  
    define( 'MULTISITE', true );  
    define( 'SUBDOMAIN_INSTALL', true );  
    $base = '/';  
    define( 'DOMAIN_CURRENT_SITE', 'xn--vrnamo-bua.nu' );  
    define( 'PATH_CURRENT_SITE', '/' );  
    define( 'SITE_ID_CURRENT_SITE', 1 );  
    define( 'BLOG_ID_CURRENT_SITE', 1 );  
    define('SUNRISE', 'on');  

Thanks.

share|improve this question
add comment

1 Answer

If you;re wildcard subdomain is redirecting to the main site, then the wildcard setup on the host is incorrect. Or they do not support it.

Setting up the wildcard in the DNS records is not the only step. Some shared hosts do not support it or require a dedicated IP address.

Also if you're trying this on an add-on domain and not the main domain of the web account, it also will not work.

So it's not the config file or the htacess at all. You really need to ask your webhost.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.