Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using the theme 'Newport' from ThemeForest. Everything was all ok however I took over this site and the previous site manager made a few mistakes so I had to remove a few of his images and replace with valid code. Being not that used to Wordpress and more used to dealing with raw code, I assume I inadvertently deleted a shortcode that displays the banner on the homepage.

I have tried everything to get this banner to appear back on the homepage with no luck. I even completely deleted the theme and reuploaded it however still no banner on homepage.

As this banner/slider is not a plugin I am struggling to find any documentation or support and I see now that this is part of the Newport theme. In the theme settings, the 'Slider' option is set to Nivo in the 'Homepage' section so it is enabled and should be there.

Can anyone help as I'm baffled as to what the problem is?

share|improve this question
    
As this isn't a freely available theme you are going to have a hard time getting help with it. If you can re-download the original you could compare it to what you have now. I'd suggest looking at the front-page.php or home.php or index.php templates. –  helgatheviking Sep 25 '13 at 16:43
    
That's the thing, according to the 'homepage-template.php' file, the slider banner is there and active. –  jfar_magnetik Sep 25 '13 at 19:33
    
Unfortunately I dont have access to download the original theme again either right now. Like I say though, before I simply changed the image code to sort it out, the banner was there –  jfar_magnetik Sep 25 '13 at 19:48
    
Also unfortunately, "Before you changed the image code" doesn't tell us anything about the code. Try posting the template code in your question. Also, verify that your page is still running this template and isn't running the default page template. –  helgatheviking Sep 26 '13 at 14:06
    
Check for JavaScript errors and run your code through a validation and see if anything pops out at you. Disable all plugins, clear your cache. –  BandonRandon Sep 27 '13 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.