Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm appending some posts on a click event to a twentyeleven child theme. For some reason though it only works when I use the query_posts loop and not a wp_query loop. For instance here's my wp_query loop:

$args = array('year' => $year,'monthnum' => $month);
$loop = new WP_Query($args);
if($loop->have_posts()) { 
while($loop->have_posts()) { 
the_post();
echo get_template_part( 'content');
} 
} wp_reset_query(); //doesn't work

Then here's the query_posts:

query_posts(array(
       'year' => $year,
       'monthnum' => $month
));

// our loop
if (have_posts()) {
while (have_posts()){
the_post();
get_template_part( 'content');
       }
}
wp_reset_query();

I've been told to avoid query posts like the plague so I'd rather use wp_query. Any thoughts on why this is happening?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Calling the_post() operates on the global $wp_query, for your custom query you need to call the method of the query object: $loop->the_post().

share|improve this answer
    
ahhhh... my bad, completely missed that. –  UzumakiDev Sep 17 '13 at 6:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.