WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting a Javascript error on the wp-admin/post.php page which prevents me from adding tags/editing the post's link.. pretty much everything with JS... anyway, the error is:

> Error: d.delegate is not a function
> Source File:
> http://www.mysite.com/wp-admin/load-scripts.php?c=1&load=hoverIntent,common,jquery-color,schedule,wp-ajax-response,autosave,wp-lists,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-resizable,jquery-query,admin-comments,suggest,jquery-ui-sortable,postbox,post,word-count,thickbox,media-upload&ver=c1c854f5d9062306d43d7331055686c9
> Line: 42

Only solution that seemed to work was downgrading the Wordpress website to 3.0.5
I'm not sure why is this happening, but after 5 hours of debugging - I don't care

share|improve this question
Any plugins enabled? Tried with them off? Tried another browser? Another theme? – t31os Mar 8 '11 at 11:34
yes, yes, yes, yes. :I – Asaf Mar 8 '11 at 20:34
¿Any thought on this? same problem here. – user4590 Apr 11 '11 at 13:33
What OS and what browsers have you tried this on? Does this happen on a 'clean' vanilla WordPress installation? – John P Bloch Apr 11 '11 at 13:55
Start with a clean install of WordPress: clean database, default WordPress install, no Plugins, TwentyTen Theme. If you do all of the above, can you verify that you still get this script error? – Chip Bennett Apr 11 '11 at 15:11

I'd suggest disabling script concatenation and/or compression to see if that helps. You can do this by adding the following to the wp-config.php file:

define( 'CONCATENATE_SCRIPTS', false );
define( 'COMPRESS_SCRIPTS', false );

And maybe even script debugging to..

define( 'SCRIPT_DEBUG', true );

Are you using any caching plugins?

The most common reason for seeing that message seems to be running an older version of jQuery, ie. anything lower than 1.4.2 ... do you have any plugins that load jQuery?

share|improve this answer

Is javascript working anywhere in the back-end? i.e. is javascript working on your Dashboard? In the edit screens for other post-types (e.g. Pages)?

If javascript is not working anywhere in your back-end, try adding the following to wp-config.php, right after your database configuration:

define('CONCATENATE_SCRIPTS', false);

This seems to fix some pesky javascript issues on the back-end, especially if you're getting conflicts with other script minimization functionality (e.g. via caching plugins, or a proxy/CDN service).

share|improve this answer
Had the same issue and this fixed it for me. Thanks! – Jarett Millard Oct 25 '11 at 20:15

If you've verified that the error still occurs after disabling all plugins and switching back to the default/included theme, then you can try reinstalling WordPress. Sometimes an individual file (or two) can be corrupted during the download of an update.

To re-install WordPress, log into the admin part of your WordPress site and go to the Updates page (http://yourblogurl/wp-admin/update-core.php). There you should see a button labelled "Re-install Automatically". That will re-download the WordPress files, overwriting anything that may have been previously corrupted.

share|improve this answer
It might sound unbelievable, but I tried switching a theme, I completely deleted my theme and installed another, I re-installed the wordpress as well as compared the original to what I have - they matched. Could it be something in the database? – Asaf Mar 22 '11 at 19:49

I had the exact same problem, I solved the issue by disabling a plugin and then went into my pages, then returned to the plugins and enabled the plugin again, the plugin that was causing the problem was advanced custom fields.

I also manually updated jQuery in wp-includs/js/jquery from version 1.4.1 to 1.7.

Hope that helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.