Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using the more types, more fields and more taxonomies plugins and they're beyond excellent. However, I've found that once I remove the main wysiwyg block I no longer have access to the media upload buttons. enter image description here

I've searched extensively for an option that would give me a new upload field or different buttons but have been unsuccessful. I read this brilliant answer by MathSmath But I'm unsure how I would implement it with more-fields. I also found an article indicating that the developer wouldn't provide this option so I'm stuck figuring it out myself.

I've gone so deep down the rabbit hole with these plugins that there's no turning back. Any help would be immensely appreciated.

share|improve this question
add comment

3 Answers

Zach, can you post a pastebin or other code to show how you edited? Post in that other forum too, maybe they can incorporate into next version....

share|improve this answer
    
well, since zach doesn't want to share his code, a quick solution to those who find this, add a "featured image" metabox to your custom post type (supports => thumbnail) and you can use that to upload images to gallery. inelegant, but it works. –  dama_do_bling Mar 15 '11 at 12:00
    
ok so I went ahead and created a pastebin post with the code I was working with pastebin.com/vA4yeXxp. It absolutely shows the media upload button and field but doesn't pop the thick-box. Let me know if you have any ideas. –  Zach Shallbetter Mar 21 '11 at 16:34
    
Here's another post related to the port I'm trying to do webmaster-source.com/2010/01/08/… –  Zach Shallbetter Mar 21 '11 at 16:50
    
zach, there are a few things wrong with that script, i'm gonna try to fix it and report back. you copied and pasted but its checking certain conditionals and therefore not putting the jquery in the admin header which is likely the problem –  dama_do_bling Mar 21 '11 at 21:54
    
@yonation thanks! Also found this while browsing the "related" panel to the right wordpress.stackexchange.com/questions/4307/… –  Zach Shallbetter Mar 22 '11 at 15:51
show 3 more comments

Take a look at Jan's answer to Attaching media to custom posts without editor you'll see that the post type must support either "editor" or "thumbnail" to include it by default, but he also shows how to include it yourself.

share|improve this answer
    
I'm completely unsure how to do this with the more_fields plugin. I've been working with the link below a bit this morning but haven't gotten the thickbox to pop. I'll play with the one you posted to see if I can get any further with it. If you have any idea please let me know. webmaster-source.com/2010/01/08/… –  Zach Shallbetter Mar 11 '11 at 20:24
    
You wont be able to do it using more fields unless you edit so of the plugin files. The plugin creates the metabox using its own code and you won't be able to add the code you need to display the media upload thickbox. Your best chance is to create your own metabox. –  Bainternet Mar 11 '11 at 20:34
    
I was able to add the upload field from the tutorial within more-fields-field-types.php. the only thing I couldn't pull off was getting the tickbox to launch. –  Zach Shallbetter Mar 11 '11 at 20:46
    
Ok so you are editing the plugins file, nice create a pastebin of your code and i'll take a look –  Bainternet Mar 12 '11 at 0:58
add comment

This seems to be a known bug that they're not responding to, see here on their forum:

http://more-plugins.se/forum/topic/insert-image-button-not-working

share|improve this answer
    
Thanks James, I posted to it as well. I sincerely need this ability in some form. Even if I could just add a custom bar that allows for media upload within custom posts that would be fine. –  Zach Shallbetter Mar 11 '11 at 19:13
    
It's not a plugin bug its cuased by the post type that dosen't support either the editor or thumbnail so the media upload scripts are not included. –  Bainternet Mar 11 '11 at 19:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.