Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When one creates a page in the Dashboard (Pages -> Create new) it always appears in the menu and that is the way it should be.

But now I want to create a page that does not appear in the menu at all. How do I do that?

I'm using a plugin called Nice navigation for animated menus and the theme I'm using is called Fiver

Here is the site I'm working on.

Edit:

This Nice navigation plugin has an arguments box in the Nice Nav widget.

All I did was add "exclude=17757" (not <?php wp_list_pages('exclude=17757' ); ?>) in the box and it now works fine. This post helped me.

Sorry, I could'nt answer my own question.

share|improve this question
    
I'm afraid, I never used Nice Navigation. But have you tried: in wp-admin > appearance > menus; then choosing the menu you want to modify, uncheck "Automatically add new top-level pages" and save? –  Mayeenul Islam Aug 21 '13 at 8:05
    
Thanks, I tried this - did'nt work. That box is already unchecked. –  DilbertFan Aug 21 '13 at 10:23
add comment

1 Answer

Try this plugin: http://wordpress.org/plugins/exclude-pages/

If Nice navigation uses wp_list_pages to show the pages in the menu, it should work.

share|improve this answer
    
Yes, I just found this plugin and others say it works fine! But I'd rather keep plugins to a minimum and also, it seems to me it hasn't been updated for a while. Yes, you are right, Nice navigation uses wp_list_pages. –  DilbertFan Aug 21 '13 at 10:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.