Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I remember, I had edited some part of my theme for optimizing the title values. Currently in google I see this.

Whereas when I open a post, the site name is not appended to the post title.

I looked at the header.php of my theme and found the following line:

<title><?php seotitles(); ?></title>

I am using "All in one SEO" plugin and have set the title and description of each post manually and when I do so, I don't append the site name in the post name.

How can I bring what I see in google and what the user sees in sync with each other?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

There is actually nothing you can do about this. Google changed their algorithm a few months ago where they will sometimes determine the title in their results if they feel it's a better fit.

I noticed this when working on the SEO for the last company I worked for. When searching "channel letters detroit" the results gave "Channel Letters - Detroit Sign Company SIGNARAMA Troy" for http://michigansignshops.com/products/outdoor-signs/channel-letters/, while the page title is "Detroit Channel Letters, Fast Fabrication & Cost Effective | SIGNARAMA".

Joost de Valk from Yoast (Author of WordPress SEO, which is very similar to All in one SEO) actually explains a little more of this in Why Google won't display the right page title.

share|improve this answer

Ian Stewart's tutorial shows an understandable and SEO-friendly <title>, you can follow

<title><?php
    if ( is_single() ) { single_post_title(); print ' - '; bloginfo('name'); }
    elseif ( is_home() || is_front_page() ) { bloginfo('name'); print ' - '; bloginfo('description'); get_page_number(); }
    elseif ( is_page() ) { single_post_title(''); }
    elseif ( is_search() ) { bloginfo('name'); print ' - Search results for ' . esc_html($s); get_page_number(); }
    elseif ( is_404() ) { bloginfo('name'); print ' - Not Found'; }
    else { bloginfo('name'); wp_title('-'); get_page_number(); }
?></title>

It'll put a title into your post page title like:

GET and POST requests - Java Experience

I hope that'll work for you. But don't know what are the settings you need to change into the "All in one SEO" settings. Good Luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.