Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I can switch to default and everything works, but once permalinks is set i get the 404. The thing is I've been using permalinks for years without problems. I can't find what went wrong as I had not made any changes in weeks. It happened all of a sudden.

I tried finding the .htaccess (showing hidden files) but to no avail.

Does wordpress update itself perhaps? I notice there's an admin bar at the top of my page when logged in...

Thanks

share|improve this question

2 Answers 2

I don't think your permalinks will work without the .htaccess file. If you create a blank one, set the permissions to 777 and try to update your permalinks again, WordPress should automatically add the rules. Then be sure to change the permissions back!

share|improve this answer
    
toss it where the index.php file is? –  Adam Mar 3 '11 at 15:51
    
Usually in the root folder of your site, or the root of your WordPress installation, depending on how it's installed. Here's some info on wordpress.org about permalinks. –  Dalton Mar 3 '11 at 15:55

Create a .htaccess file in the root directory of your Wordpress install (where the index.php etc is) and set it to what WP tells you to when you turn permalinks on.

share|improve this answer
    
in the wp-content folder... the prompt just says permalinks structure update. It's so weird because it happened out of the blue. –  Adam Mar 3 '11 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.