Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just downloaded the WMD Editor plugin.
For some reason is not showing up in the Plugins menu.

the folder is called wmd-editor/

wmd-editor.php:

<?php
/*
Plugin Name: WMD Editor
Plugin URI: http://c.hadcoleman.com/wordpress/wmd-editor
Description: Adds the <a href="http://wmd-editor.com/">WMD Editor</a> to the comment field, to make life easier for your commenters.
Version: 1.0
Author: Chad Coleman
Author URI: http://c.hadcoleman.com
 */

/*
This is a simple plugin that just adds the javascript call to the header of your template. You can gather more info on this project at http://code.google.com/p/wmd/
*/ 

    // function for head output sytles
    function wmd_header() {
        global $cb_path;
        $cb_path = get_bloginfo('wpurl')."/wp-content/plugins/wmd-editor";  //URL to the plugin directory
        $hHead = "\n"."<!-- Start WMD Editor -->"."\n";
        $hHead .= " <script language=\"javascript\" type=\"text/javascript\" src=\"{$cb_path}/wmd.js\" ></script>\n";
        $hHead .= "<!-- End WMD Editor -->"."\n";
        print($hHead);
    }

    add_action('wp_head', 'wmd_header'); ?>
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Must be something you have installed or custom code causing the issue, it appears just fine for me.

enter image description here

If your question was actually why there's no additional menu item on the admin side then the answer would be because not every plugin has an admin page, some provide configuration options, others just do something with no configurable options(depends on the intent of the author i suppose).

Hope i could help in any case..

share|improve this answer
    
Thanks for the fast response. Yeah the plugin is OK like you said. I created a new folder and it worked. Could it be some chmod rewrite issue? –  janoChen Mar 3 '11 at 15:22
    
Possibly, never had that issue myself. –  t31os Mar 3 '11 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.