WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Wordpress site that is hosted on Windows Azure, with the database hosted separately. Every time I try to update a post I get a 502 error, specifically:

502 - Web server received an invalid response while acting as a gateway or proxy server.

The DB provider says everything is fine - does anyone know how I can troubleshoot this problem? Oddly enough - basic reads are fine - the error only occurs when I try to update a post.

share|improve this question
It sounds like a db connection timeout ;-) Can you save other settings or pages without problems? – birgire Sep 11 '13 at 1:40
Nope - I can do reads, but no writes or edits. Now that I think about it, I can only do http gets, not http posts. – Steve French Sep 11 '13 at 11:46
Is your application set to 32 or 64 bits (see here) – birgire Sep 11 '13 at 13:20
I just reset it to 32 bit - absolutely no change. – Steve French Sep 12 '13 at 14:45
And you get the same for plain vanilla mysql update command via php without going through WordPress? – birgire Sep 16 '13 at 14:46
up vote 0 down vote accepted

I turned on failed request tracing, and saw many entries (not errors, but entries) for Glimpse (I have wordpress running as a subdirectory of my .net site). Glimpse is not supposed to be running in production - but apparently it does. When I removed Glimpse everything worked just fine. Live and learn I guess.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.