Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am taking over a wordpress website at work. All of the pages currently do not have a 'Leave a Reply' comment section. When I make a new page, this section exists on the new page. How do I remove it? As far as I can see all of the options as far as the page goes are the same.

I have already tried to uncheck 'Allow people to post comments on new articles' but it didn't do anything

share|improve this question
2  
This really depends on how the current pages are set up. Are they using templates (under Page Attributes in admin)? Has the 'Allow comments' checkbox been unchecked on a case by case basis? Are they using page specific templates? –  vancoder Aug 6 '13 at 19:10
add comment

1 Answer

up vote 2 down vote accepted

If you want to be rid of comments on your site, one option is to remove the code from your theme files.

You would need to search single.php, home.php, page.php, etc. within wp-content/themes/*your-active-theme* and find:

<? php comments_template(); ?>

Remove that and the comments section should disappear.

NOTE: this change will be undone if you update the theme files. Modifying a child-theme is a much better practice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.