Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Two days ago I discovered a huge problem with my Wordpress media editor. I just can't edit any image because it doesn't appear. Wordpress shows only small icon of broken picture... I was looking for the problem and now I'm pretty sure functions.php file causes my problem. I realized when I remove functions.php - problem disappear too. But what is strange - editor doesn't work when functions.php is EMPTY.

I tried everything. I turned off all of my plugins, but I can't rid of my functions.php, because It's too important for me. On the other hand the problem with images is really irritating...

Thanks in advance.

share|improve this question
2  
Removing functions.php might be too aggressive. What is there in relation to 'media' or 'attachment' or 'image' that might be influencing your installation? –  GhostToast Jul 25 '13 at 19:09
    
In functions.php there are several functions related to 'images' like thumbnails. However I think functions don't cause the problem because, how I mentioned, when I make empty functions.php file the problem immediately appears. –  muppet1906 Jul 25 '13 at 20:02
1  
I solved the problem: it was bad formatting of functions.php file - UTF-8. When i turned it to UTF-8 without BOM my problem just disappear. –  muppet1906 Jul 26 '13 at 7:57
    
Muppet, you could submit your solution as an answer and select it as correct, if you wish. For closure. –  GhostToast Jul 26 '13 at 15:16

1 Answer 1

I solved the problem: it was bad formatting of functions.php file - UTF-8. When i turned it to UTF-8 without BOM my problem just disappear.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.