Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

After upgrading to 3.1 I am seeing this issue.

I use custom post types and when you click on the menu items either Games, Entertainment or Tech it gets the class current-menu-item but home link still has it also.

I am using the custom menu's built into WordPress and for the links and they are just custom links pointing to:

  • Home: http://www.flesheatingzipper.com
  • Games: http://www.flesheatingzipper.com/games/
  • Entertainment: http://www.flesheatingzipper.com/entertainment/
  • Tech: http://www.flesheatingzipper.com/tech/
  • About: Links to page, about

Here is the site: http://www.flesheatingzipper.com/

share|improve this question
1  
You'll need to share a bit more details, like how your menu is set up etc. . –  wyrfel Feb 28 '11 at 13:31
    
Updated the original post. –  kel Feb 28 '11 at 22:44
    
Can't replicate this on my install, home link only gets current on the home page, how are you adding the home link to the menu? (custom link?) Same question for problem links, are they custom or pages, or something else? –  t31os Feb 28 '11 at 22:51
    
The home, games, entertainment and tech are custom links. About and contact are page links. When you click on one of the page links the home link does not get the class. It only has the class when you click on the games, entertainment or tech links. Those links are of course pulling type-[games/entertainment/tech].php. Like I was saying it was working fine in 3.0 and just started happening after upgrading to 3.1. –  kel Mar 5 '11 at 7:42
add comment

1 Answer

Have you tried using the checkboxes / add Pages / add Categories rather than custom links when adding items to the menu? It's sorta the opposite problem, but I've run into issues where WP does not recognize custom links as "this page" - maybe the fix is the same.

** EDIT **

I just ran across this thread in the WP forums which might help with your issue. Read comments from this point on down for a few suggested workarounds. http://wordpress.org/support/topic/custom-post-type-parent#post-1775314

share|improve this answer
    
They are custom post types so they don't show up as an option check off. –  kel Mar 5 '11 at 7:43
    
Thanks for searching. I just ended up using JS to remove the class. –  kel Mar 13 '11 at 9:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.