Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've enabled built-in password protection on one of my pages. The password form shows up, I enter a password, press Submit button and I'm redirected to my front page.

Now if I revisit the protected page, it will be unlocked (if the password was correct). But I think after I enter the password, I should land directly on the page I'm trying to access, right?

I'm using Wordpress 3.5.2 with a custom theme. What I've tried:

  • tested it on another blog with WP 3.5.2
  • switched theme to unmodified Twenty Twelve
  • disabled all plugins
  • clean WP install on a local server

No luck with any of these, still the same problem - I'm redirected to the server's root (i.e. example.com/, not example.com/wordpress or example.com/wordpress/passpage).

Is it a bug or intended behavior? Is there any workaround I could use?

share|improve this question

1 Answer 1

Turns out it was a problem with my browser blocking HTTP referrers.

Disabling referrer blocking or switching to another browser solves the issue.

(related Trac ticket)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.