WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working on a local install of a live wordpress site, all links from the main page show Not Found errors. all .htaccess files are all present.

The problem is that every page except for the home page is showing a Not Found error, I can't find any problems with permissions or anything else that would cause it to not work.

Is there anything that I can try that I might be overlooking? I apologize for the vauge questions but I am having trouble figuring out where to start.

share|improve this question
Live site is installed in domain root? What is the address of local site? How did you migrate it? Have you recreated htaccess files (with correct contents)? Have you updated posts permalinks? – Krzysiek Dróżdż Jul 12 '13 at 20:18
Sounds like permalinks need refreshed. Settings -> Permalinks. Try again. – GhostToast Jul 12 '13 at 20:27
the address is localhost:8888/sites/GaugeSite (I am using MAMP) I migrated it with SSH and a tarball, I made sure the .htaccess files are good to go, and I updated the permalinks as GhostToast suggests, problems still persist – Ty Underwood Jul 12 '13 at 21:00
Are you allowed by your Apache configuration to use .htaccess? Check your config files for an AllowOverride directive. If you see AllowOverride None, you'll need to change this (most of my sites use AllowOverride All) and restart your Apache service/daemon. – Pat J Jul 12 '13 at 21:12

With localhost, you need to make sure that your mod_rewrite is on. You can do this in your httpd.conf file in MAMP. MAMP > CONF > APACHE > ORIGINAL > httpd.conf. Uncomment this line: LoadModule rewrite_module modules/mod_rewrite.so

share|improve this answer
… and restart the server then. – toscho Jul 12 '13 at 23:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.