Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am going to submit my first plugin to the repository. How do I find out the Requires tag value for which my plugin would work? I know its somewhat vague, but how do you guys figure out? Like my plugin just add some info in the head section. The only thing required for its functionality is wp_head hook. So I just did a grep and checked the inline documentation that it was introduced in WP v1.2

So am I right? This is how I should be doing it? Any tips?

share|improve this question
    

1 Answer 1

up vote 1 down vote accepted

Yepp, if you really only use that hook, that would be the way to go. But it's pretty likely you also use a couple of WP functions...if so, you should check these functions, too, before going too low with your required version.

Generally, i wouldn't go below 2.0 (which i smore than 5 years old) for any new plugin. I think even going lower than 2.5, which is about 3 years old, is unnecessary.

share|improve this answer
    
Thanks! It really doesn't use anything other than wp_head hook. Its here - wp.me/pah88-ek –  Ashfame Feb 27 '11 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.