Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I unchecked both options in the discussion area (so the one where they need a post to comment and administrator has to approve), but still, my users can't put their comments without me approving it.

Has someone a solution for this glitch? Why on earth can't they post a comment? And if they post one, the second one needs to be approved?

share|improve this question

2 Answers 2

Dashboard - options - discussions

Before a comment appears:

  • An administrator must always approve the comment
  • Comment author must fill out name and e-mail
  • Comment author must have a previously approved comment

Uncheck at least 1 and 3.

share|improve this answer
    
That's what I stated in my post: already done that. That's not the problem brother. –  Johan Jul 9 '13 at 5:51
    
If that not work, you can change your theme to default wordpress given Theme and check if it fixed, then it should be your theme code. Or you can disable plugins and check so you will know what cause the problem. Normally The above fix should work with Wordpress setup. –  Shahinul Islam Jul 9 '13 at 7:36
up vote 0 down vote accepted

I used multiple links in a comment and I saw that there was an option to avoid comments that have more links than 2 in (moderate comments). I set it to 0 and now it works like a charm.

Wordpress, oh Wordpress!

share|improve this answer

protected by Community Sep 20 at 4:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.