Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

There are 11 plugin updates available for a WordPress site, so I tried updating it.

However, when I do that I get an error:

Public and Private keys incorrect for <username>

I have made keys for my own user on the server, but that is not the problem I am asking about. The problem is that I cannot change any details in the Connection Information page (shown below). There are details already there, but they cannot be changed. I can select them, but I cannot delete or edit them. I have tried in different browsers.

What could be causing this? My WordPress account is set as an Administrator.


Connection Information

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I believe that you have some or all of these defined somewhere, probably wp-config.php.

define('FTP_PUBKEY', '/home/username/.ssh/id_rsa.pub');
define('FTP_PRIKEY', '/home/username/.ssh/id_rsa');
define('FTP_USER', 'username');
define('FTP_PASS', 'password');
define('FTP_HOST', 'ftp.example.org');
define('FTP_SSL', false);

http://codex.wordpress.org/Editing_wp-config.php

I am able to duplicate the issue and resolve it by manipulating those constants.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.