Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am on this screen of WordPress:

enter image description here

And when I press save, the meta description tag for my home page gets set, but my <title> tag does not. Would anyone know why this happens?

Also, for some reason the <title> tag doesn't have the meta keyword in there on the home page. Would anyone know why that happens?

share|improve this question

migrated from webmasters.stackexchange.com Jul 2 '13 at 17:30

This question came from our site for pro webmasters.

Make sure you have wp_head() in your theme (most likely in header.php) see: yoast.com/wordpress/seo/faq/… Aside, UPDATE YOUR PLUGINS! –  BandonRandon Jul 2 '13 at 17:38
@BandonRandon: But this plugins doesn't need wp_head to output title. Title should be printed out with wp_title function. And This plugin filters this value. Yes wp_head is important, but it wouldn't cause problems with title. –  Krzysiek Dróżdż Jul 2 '13 at 17:55
So the question is: is there wp_title() function call in your themes header.php file? –  Krzysiek Dróżdż Jul 2 '13 at 17:55
@KrzysiekDróżdż Thank you. How would I check whether there is that function? I am new to Wordpress. –  Genadinik Jul 2 '13 at 18:21
@Genadinik: You can use FTP client (wp-content/themes/<YOUR_THEME_NAME>/header.php) and look in there. Or use editor in wp-admin (Appearance->Editor). –  Krzysiek Dróżdż Jul 2 '13 at 18:26

2 Answers 2

up vote 2 down vote accepted

It's normal. If you entered a website title in Settings => General, this is the title will be taken into account.

WordPress SEO by Yoast SEO plugin doesn't rewrite the title chosen in WordPress by default.

share|improve this answer
Thank you that worked perfectly :) –  Genadinik Jul 2 '13 at 18:32
You're welcome ;-). –  Zistoloen Jul 2 '13 at 18:37

Expanding on Zistoloen's answer:

In Version 1.4.12 there is an option under the General tab of Titles & Metas to "Force Rewrite Titles" and this overrides the default mentioned.

share|improve this answer
That's incorrect. That setting is under the General Tab, not the home tab he has posted a screen shot of. –  moobot Jul 3 '13 at 5:33
@moobot You are correct. I'll edit. –  JCL1178 Jul 3 '13 at 17:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.