WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have developed a site www.mainsite.com based on Ruby on Rails hosted on Heroku. I have also developed a blogging site based on Wordpress at blog.mainsite.com hosted on Dreamhost. I want our users to interact with www.mainsite.com/blog instead of blog.mainsite.com. I have each site function correctly, and the DNS setup correctly. I also set up reverse proxy in Rails to route traffic reverse_proxy /^/blog(/.*)$/, 'http://blog.mainsite.com$1', opts={:preserve_host => true}

Most of the time it work. After I messed with the permalinks and restored it, now in Wordpress, whenever I upload a media file (image), it always sends me to www.mainsite.com/wp-admin (404) instead of www.mainsite.com/blog/wp-admin. What is the problem?

share|improve this question

migrated from stackoverflow.com Jun 28 '13 at 11:17

This question came from our site for professional and enthusiast programmers.

On the admin panel, under Settings -> General Settings, make sure the "WordPress Address (URL)" and "Site Address (URL)" are correct. Also, check out the Wordpress StackExchange.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.