Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Since updating to Wordpress 3.5 I've had my updates of pages and posts become excessively slow. I've been timing them and they take 40-80 seconds to update.

I've spent the last 2 hours reading and trying everything I can find in the Wordpress.org forums yet nothing works.

I use maxcdn and CloudFlare for the frontside but the backside is unbearable.

I am on a MU install using 3.5.2 and I have disabled and tested each plugin. Seems to be a Wordpress issue and I'm looking for a workaround.

I'm on dual core VPS with 3GB of ram.

share|improve this question
    
hey gabearnold, how far have you gone with that? Have you found where is the bottleneck? Is it your Server(Apache/Nginx), your database, your application? what do the logs say? –  medina Jun 27 '13 at 0:30
    
It's apache. I am looking in the logs and TOP in MySQL and nothing glaring stands out... –  gabearnold Jun 27 '13 at 0:54
    
To get sure the problem is not with your MYSQL you can run SHOW PROCESSLIST; when trying to insert a new post and see if there is any query taking longer then it should. Or rather, turn on your slow_query_log... ;-) –  medina Jun 27 '13 at 1:36
    
It's not taking quite as long as you're reporting, but I've seen a definite (albeit anecdotal) slowness on the backend since updating as well. –  Chris Ferdinandi Jun 27 '13 at 3:45
add comment

migrated from stackoverflow.com Jun 27 '13 at 13:44

This question came from our site for professional and enthusiast programmers.

2 Answers

There's a plugin called Debug Bar which you can find at http://wordpress.org/plugins/debug-bar/ Don't leave this enabled in production! But it will tattle on slow MySQL queries.

You might also wish to try using WP Clean Up. http://wordpress.org/plugins/wp-clean-up/ This flushes out stale entries in your database, and does a little bit of table reorg/optimization.

share|improve this answer
add comment

I had the same thing today. It turned out that WP Maintenance Mode plugin slowed down my website. After I deactivated the plugin, all was good again.

Maybe it helps someone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.