Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Image uploads (slowly), and displays in the media window.

But size shows "(0 × 0)" and if I try to use Edit Image button I can't edit the image but instead get this message:

"Image data does not exist. Please re-upload the image."

I have 2 different WP installs each with unique plugins, and the problem exists on both installs

Is it WP 3.1 recent upgrade? Is it a plugin? Other?

share|improve this question
    
Usually this happens when you upload very large images, due to PHP timing out. Try uploading an image with a small image size and see if that works. If so, you'll have to up the PHP memory limit in .htaccess or wp-config. –  Michelle Feb 24 '11 at 22:35
    
OK, if I waited 30 more minutes I could have avoided this post... I solved it... The problem was the WP Smush.it` plugin. Deactivate this plugin and all works well. I had already increased my memory limits, and the file size was only about 200k. –  SiteSubscribe Feb 25 '11 at 1:20
add comment

1 Answer

OK, if I waited 90 more minutes I could have avoided this post... I solved it...

The problem was the **WP Smush.it** plugin. Deactivate this plugin and all works well.

I've had problems with this plugin before in different ways...very finnicky.

I had already increased my memory limits, and the file size was only about 200k. That wasn't my particular issue.

share|improve this answer
    
Interesting. I've used WP-SmushIT on several different sites and have never had a single problem with it. –  Pippin Apr 26 '11 at 1:57
    
I haven't ever had issue with the plugin either. What host are you using? In case that's the cause. –  developdaly Apr 6 '12 at 20:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.