Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I recently updated to WordPress 3.1, and with that update, something very interesting happened. Links became unclickable -- clicking on any link would literally result in nothing happening. Interestingly enough, all of the jQuery stuff still works. Removing the jQuery Mobile script gets rid of the problem. The error being generated was:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXMLHttpRequest.open]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: http://......./wp-includes/js/jquery/jquery.js?ver=1.4.4 :: anonymous :: line 138"  data: no]

Any idea how to fix this?

share|improve this question
    
0% accept rate!! Please go back and accept some of the answers to your previous questions –  anu Mar 27 '11 at 10:28
    
Anu, the answers I've gotten have either not ended up working or weren't what I was looking for. Do you think I should still accept an answer? –  epaps Mar 28 '11 at 2:51
    
well in most of those cases you haven't gone back and commented or responded to work through to an answer. –  anu Mar 28 '11 at 6:51
    
Not true. Check again. –  epaps Mar 28 '11 at 7:04
    
I did check, anyway, just offering some advice on how to get better responses from more people, so good luck. –  anu Mar 28 '11 at 8:39

1 Answer 1

Just a guess, but your error message indicates that WordPress is using jQuery 1.4.4. If you look at the jQuery Mobile website, they're using 1.5. Have you tried using wp_enqueue_script to use a jQuery 1.5? You'd want to try something like:

<?php
function my_init_method() {
    if (!is_admin()) {
        wp_deregister_script( 'jquery' );
        wp_register_script( 'jquery', 'http://ajax.googleapis.com/ajax/libs/jquery/1.5/jquery.min.js');
        wp_enqueue_script( 'jquery' );
    }
}    

add_action('init', 'my_init_method');
?>
share|improve this answer
    
Thanks for the response. Unfortunately, I've already tried that. When I use 1.5, no error appears in the Firefox console -- links just don't work without any warning. –  epaps Feb 24 '11 at 22:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.