Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I was having this error that a random post said it had zero posts (using comments_number()) and when I went to the comment section it also said "No Comments" but it listed a comment.

On a hunch I changed the name from "Name @ Website" to "Name - Website" and it started showing the correct post count.

How do I allow special characters in the name?

share|improve this question
    
Are you sure you didn't change the comment from unapproved to approved in the process? I can't replicate the problem you're having on a vanilla install of WordPress. Try disabling all plugins if problem persists. –  TheDeadMedic Jun 21 '13 at 2:18
    
Yeah, quite sure. I'd disable plugins but a few of them clear their settings when disabled, so I'm kinda afraid of that. –  Little Big Bot Jun 25 '13 at 19:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.