Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have developed a Wordpress site on staging server. It is working absolutely fine.

When I moved the site to live server, media upload URLs changed to relative.

Staging media URL as image source:

<img src="http://staging.myurl.com/wp-content/uploads/2013/06/featured-bg-150x150.jpg">

Live media URL as image source:

<img src="/wp-content/uploads/2013/06/featured-bg-150x150.jpg">

Did I need to take care of something while moving site? Or this issue may be server dependent.

Another cause what I think can be from the SEO plugin installed, I'm not sure about this.

Note: Both servers are at different domains.

Thanks in advance.

share|improve this question
    
What did you do when you moved it? Did you follow this or any other guide? codex.wordpress.org/Moving_WordPress It's very hard to help with such limited information. –  GhostToast Jun 20 '13 at 20:32
    
@GhostToast: I've done it hundred times, with no issue. I've already followed the link you shared. To my surprise this happen first time. What information you want me to share with you? –  Harpreet K. Jun 20 '13 at 20:35
    
Is your new server running mod_pagespeed by any chance? –  s_ha_dum Jun 20 '13 at 20:37
    
@s_ha_dum: I've no idea, How would I know about this? –  Harpreet K. Jun 20 '13 at 20:39
    
phpinfo. It is a bit of a long shot but some of the pagespeed rules do strip domain names. –  s_ha_dum Jun 20 '13 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.