Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm creating custom theme for my personal website using Wordpress 3.5.1. I have problem with the WordPress custom post type and taxonomy, here's the detail:

  • custom post type name: articles
  • taxonomy name: article-categories
  • rewrite slug: articles (same with my cpt)

Currently my URL is like this:

  • example.com/articles --> archive-articles.php (it works)

  • example.com/articles/taxo-parent --> taxonomy.php (it works)

  • example.com/articles/taxo-child --> taxonomy.php (it works)

  • example.com/articles/post-title --> I use single-articles.php, it doesn't work

I want my URL to be like this:

  • example.com/articles

  • example.com/articles/taxo-parent

  • example.com/articles/taxo-parent/taxo-child

  • example.com/articles/taxo-parent/taxo-child/post-title

It's been a week working with this case and search / reading post from google but still have no luck, really appreciate if you guys could help me.

Thanks

EDIT:

I use WP Custom Post Type UI plugin to create custom post type and custom taxonomy

share|improve this question
1  
try this. it works for me wordpress.stackexchange.com/questions/73889/… –  b0li Dec 29 '13 at 19:25
add comment

2 Answers

You can not name custom post_type name and taxonomy slug same because when you work on taxonomy it will work as

example.com/articles/taxo-parent --> taxonomy.php

example.com/articles/taxo-child --> taxonomy.php

But for post_type articles it will go with same url

example.com/post_type/post_in_that_post_type_slug

So this make conflict in the url's of taxonomy and post_type because initial url is same for both of them

example.com/post_type/ = example.com/articles/

example.com/taxonomy/ = example.com/articles/
share|improve this answer
add comment

You should update your permalink option after registering post type.

http://codex.wordpress.org/Function_Reference/flush_rewrite_rules

Than it should work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.