Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Permalinks not working other than set to "Default'. I want to change it to /%postname%.html, and default .htaccess is as follows:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

But sometimes it becomes …

# BEGIN WordPress

# END WordPress

… whenever I change the settings of Permalinks. I already change the permission of .htaccess to 777 and mod_rewrite is working. AllowOverride All has been set to my working directory. Any ideas?

share|improve this question
1  
What do you mean by "sometimes it becomes". That seems very weird. –  JMau Jun 15 '13 at 10:28
    
Yes, sometimes. Whenever I choose a option other than Default then clicked "save changes" at "Permalink Settings", .htacces shows the normal one to me and when I access the page WordPress said "Page not Found". But whenever I choose Default and click "Save Changes", .htacees became a file only with 2 lines "#BEGIN WordPress" and "#END WordPress", and I can access the page normally. –  user34139 Jun 16 '13 at 3:43
1  
If I were you I would not set permission of .htaccess to 777. Set this to 666. Then change permalink structure and see what happens. –  JMau Jun 16 '13 at 11:55
    
Hi TweetPressFr, I just tried, the result was just the same. –  user34139 Jun 17 '13 at 2:03
    
Then try this link –  JMau Jun 17 '13 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.