Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I want to use SSL for login/admin. However, since I'm using a shared server, my web host only provides a shared SSL. That means instead of https://www.regular-domain.com I have to go to https://servername.webhostname.com/~myusername/, which throws Wordpress off since it expects everything to be under the regular domain.

share|improve this question

1 Answer 1

Try the WP HTTPS plugin, it has a Shared SSL option. Also see discussion here.

share|improve this answer
    
I haven't been able to get that plugin set up correctly. I've installed it, unchecked all options except for the Shared SSL option, put in my SSL-protected domain, and added define('FORCE_SSL_ADMIN', true) to my wp-config.php. When I try to go to the login page I'm redirected to https://servername.webhostname.com/~myusername/~myusername/wp-login.php (note the duplicate ~myusername) and get a 404 page. –  AJM Feb 24 '11 at 23:15
    
Sorry, i'm not using the plugin myself, yet...please contact the plugin maintainer. It looks like it's not picking up what you put into the Shared SSL Host field. –  wyrfel Feb 25 '11 at 0:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.