Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

As soon as i saw the message on WPSE about the 3.1 release i immediately went a did a switch on my local installation(SVN switch).

Only issue is the wp-settings.php is trying to include a non-existant file.

Basically i'm stuck seeing the following two error messages.

Warning: require(MYPATH/wp-includes/classes.php) [function.require]: failed to open stream: No such file or directory in MYPATH\wp-settings.php on line 68

Fatal error: require() [function.require]: Failed opening required 'MYPATH/wp-includes/classes.php' (include_path='.;MYPATH/usr/local/php/includes;MYPATH/local/php/pear;MYPATH/home/admin/www/plugins/pear/PEAR') in MYPATH\wp-settings.php on line 68

MYPATH is actually a real path, i've removed that from the above quoted errors.

3.1 does not contain any such file, and i've checked my trunk installation to confirm(it's not in trunk). So what's the deal, why is the settings file still trying to include this file? Maybe an oversight with the release?

I could go grab a copy from 3.0.5, just want to hear what you guys have to say first(had this problem yourself?).

Looks like this is a local issue, i should be getting an updated wp-settings.php file, but for some reason SVN up is giving me an older copy(must be some caching issue somewhere, i assume).

I'll update the question if i figure out the problem.

UPDATE
No idea why, but seems the switch didn't quite take, wiping the svn folders and doing the checkout procedure again(like i first did when i set the directory to pull from the SVN) seems to have resolved the problem.

share|improve this question
    
Any reason you are updating via SVN rather than the built-in auto update? –  EAMann Feb 23 '11 at 18:28
    
Using SVN is quicker, and it's worked for the last few versions without a hitch(no login required, reverting core changes is easy, etc...). –  t31os Feb 23 '11 at 18:32
    
Totally odd problem, i've used switch several times to change version, this time shouldn't be different than any other. It's all working now though, thank god!.. :) –  t31os Feb 23 '11 at 18:46
    
Hehe, I expected such a question. Just … not from you. ;) –  toscho Feb 23 '11 at 19:24
    
If someone adds a You're an idiot and fudged the install somehow as an answer they'll get the accept. Still confused what went wrong exactly, but seeing as i'm the only one interacting with the installation it must be something i did(i guess).... :) –  t31os Feb 24 '11 at 1:16

2 Answers 2

up vote 3 down vote accepted

There is no reference to 'classes.php' anywhere in the WP codebase, either in the 3.1 branch or in trunk.

You probably have a modified version. Do a 'svn stat' and then a 'svn diff'.

share|improve this answer
    
Never mind, seems the switch didn't quite take, there were some issues with svn files pointing at the wrong version. Wiped the svn folders, did checkout to 3.1 on the dir again and it's all working now. –  t31os Feb 23 '11 at 18:42
    
Should of said this in the previous comment, but thanks for the feedback by the way(already fixed by the time i read the comment, but still appreciate the help).. ;) –  t31os Feb 24 '11 at 1:18
    
No problem. I actually experienced the same error shortly after (it was caused by an unversioned plugins directory in my case). –  scribu Feb 24 '11 at 17:43
    
I did in fact use the auto upgrade within Wordpress and I have the same error. If it is really the case as scribu says, then wtf? –  user3492 Feb 25 '11 at 3:30
    
Scribu you might be on to something there, but what exactly do you mean unversioned directory? I did previously have a couple of externals in the plugins folder at one point, and additionally Akistmet had to be deleted before it played nice with the new checkout, possibly related? –  t31os Feb 25 '11 at 18:34

You failed to update the files in the root of WordPress. I don't know why, but a lot of people make this simple mistake.

It is not enough to upgrade only the wp-admin and wp-includes directories. The files in the root directory, such as wp-settings.php and all the other wp-* files there, also must be upgraded.

WordPress 3.1 no longer contains a wp-include/classes.php file, and the wp-settings.php file from 3.1 doesn't try to load it.

share|improve this answer
1  
From the behaviour i saw it did seem that was what was happening, but infact was not the case, i even went so far as to delete all the files then do an SVN UP(all those in the root, plus the wp-includes/wp-admin folders).. this didn't solve the problem, and i was still fed back an older wp-settings.php file from the SVN UP. Using SVN, i right click the root folder(ie. where the given complete installation resides) and click "Update", there's no wrong way i can do that, it's the same operation i use for every update. –  t31os Feb 25 '11 at 18:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.