Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have W3 Total Cache installed so that I can serve images from my live website to a local development version. Everything seems to be working as expected, apart from the URL rewrite doesn't seem to happen on a custom post types pages.

I don't have the caching switched on, and the CDN hostname replacement is working very well on every other page.

Any ideas?

share|improve this question
add comment

1 Answer

The answer was to get http://wordpress.org/plugins/wp-regex-replace/ and simply replace the full absolutely path to the wp-content/uploads folder.

share|improve this answer
    
Another option is to export your MySQL database to a .sql file and download it locally, then do a search & replace for the live site's URL to replace it with the dev site URL. Then drop the tables in the database and import the .sql file back in. –  Christiaan Jun 3 '13 at 3:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.