Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm not sure how to word my search terms for this problem.

I've created a site in WP. So, let's assume the URL is http://example.org

The 'Contact' page would be http://example.org/contact, for example.

I want to also have a blog on this site. The blog would reside at http://example.org/blog

I have created a page named 'Blog'. I've gone to Settings > Reading and selected 'Blog' for the 'Posts page' select list. Now, when I visit the site, I don't see posts. How do I make my posts appear on http://example.org/blog given what I've done so far?

I'm not quite sure how to do that the right way. Any recommendations would be appreciated!

share|improve this question
    
Are you using a custom theme? –  Sven Jun 2 '13 at 19:36
    
Dumb check, do you have posts to see? What do you see at /blog page? –  Rarst Jun 2 '13 at 20:55
    
Sven: yep, Roots: rootstheme.com Rarst: haha yes :) The default 'Hello World' post. –  Housni Jun 3 '13 at 23:31

2 Answers 2

You say that blog will reside in http://example.org/blog. That's incorrect. It will be as a part of your installation http://example.org. Create two pages: Intro and Blog. In Settings -> Reading -> Front page displays - select - A static page -> Front page - and choose Intro, then in Blog page - choose Blog. Set your parmalinks to Post name. That's it. Add a post and go to http://example.org/blog/. You will have your post listed there.

share|improve this answer
    
Make sure that your page Blog has a slug blog otherwise the last request will look into subdirectory /blog of your installation and will fail. –  Frank P. Walentynowicz Jun 3 '13 at 0:00
    
Hey Frank, thanks for responding. Not sure if you read my entire post but I've already tried that and it didn't solve the problem. –  Housni Jun 3 '13 at 23:26
    
Go to Test which is my test installation. I've installed your theme and set it according to my instructions. You must do something wrong if it does not work for you. Making custom templates is not needed. If you want you can give me admin access to your website and I'll fix it for you. –  Frank P. Walentynowicz Jun 4 '13 at 3:11

I'm not sure if this is the best way but this is how I resolved the problem.

I created a custom template and called it 'Blog' (name is irrelevant except for use in referencing it in this post).

I then selected the 'Blog' template for the Blog page.

I customized the Blog template to display blog posts.

If anyone knows of a better way to do this, I'm all ears but I'll mark this as the solution until then.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.