Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

(I modified the question. i .e. I added hyperlink)

My website uses Jobroller theme.

The problem is that it is not compatible with WPML

I am translating themes using codestyling localization [Link to the code. It is compressed][1] Could you give me some instructions on what I need to do from here?

Jobroller does not seem to be compatible with codestyling localization.

If I am using an incompatible them, is there a way to achieve compatibility?

( I have added some of the source codes)

[1]: Code http://cafeattach.naver.net/a732bb081c2c2d9db35c320338dca1da782ad1f4/20130527_261_cafefile/24495556_1369658452761_pDfySc_zip/sample_source.zip?type=attachment

share|improve this question
2  
Please add a link to the theme code. –  toscho May 24 '13 at 10:04
    
It's called the Jobroller. I got it some time ago demos.appthemes.com/?theme=jobroller –  user45979 May 27 '13 at 7:04
    
That’s not the code, it is the rendered output. There is no answer possible without seeing how the code loads and uses the language. –  toscho May 27 '13 at 7:32
    
Jobroller is 'open source' but not free. I know this sounds strange but I am not too sure how else to put it. I don't think I can just upload the codes. –  user45979 May 27 '13 at 12:20
    
Then ask the theme support. –  toscho May 27 '13 at 12:36
show 3 more comments

2 Answers

If you’re interested in a tool to easily translate WordPress themes, have a look at the online localization platform https://poeditor.com/ It’s even got a plug-in you can use with it to integrate its API to your WordPress so that you save more time with the file management process. You can find it here: http://wordpress.org/extend/plugins/poeditor/

share|improve this answer
add comment

I haven’t seen all files in your attachment, some directories are not included, so this is just a guess:

  1. Create a directory languages in the theme for the language files.

  2. Add the following to the style.css header below License URI:

     Textdomain:  jobroller
     Domain Path: /languages
    
  3. In functions.php add:

    add_action( 'after_setup_theme', 'jobroller_load_language' );
    
    function jobroller_load_language()
    {
        load_theme_textdomain( 
            'jobroller', 
            get_template_directory() . '/languages' 
        );
    }
    
share|improve this answer
    
Thank you. It didn't work, it must be the problem with the theme. Jobroller is not compatible with WPML either and a bridge hasn't been published yet. Thank you so much anyway –  user45979 May 27 '13 at 13:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.