Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

This is driving me crazy. The code for the image is: <img src="MYLINK" />

Yet it keeps resizing my image down to 500x500 from 947x947. How do I fix this?

Also, it disregards the image map I have which lets you click on different parts of the image to go to different sites.

EDIT: This is what I'm referring to: http://macaulay.cuny.edu/eportfolios/menatwork/test-page/ Right click and check the image properties: it shows how the 947x947 has been scaled to 500x500.

share|improve this question
    
So... this is code you have in the post editor? –  bungeshea May 21 '13 at 4:47
    
the link to the image is in the MYLINK. But yes that is the code. –  Greg May 21 '13 at 4:48
    
I feel it has something to do with either Wordpress or the theme that I'm using (sliding door). –  Greg May 21 '13 at 4:49
    
If you visit the post on your website, and you view the source of the webpage, is the code the same? –  bungeshea May 21 '13 at 4:58
    
The cap on the image is a width of 500px. I was able to do everything I need, so long as I use an image of 500px width. This is a huge compromise, as this is the splash page for the site. –  Greg May 21 '13 at 5:08

2 Answers 2

If you're uploading the image via Wordpress's Media Manager, goto 'Settings > Media' in your admin panel and configure the max dimensions for the 'Large' images uploaded via this.

share|improve this answer
    
The max dimensions in the Settings>Media are 1024x1024, which is larger than what I need. Regardless, wordpress scales down the image. –  Greg May 21 '13 at 12:22
2  
There's a basic generic css overriding your image size : line 758 of your style.css #content img { height: auto; max-width: 500px; margin-top: 0; margin-right: 0; margin-bottom: 0; } Your problem comes from here. –  user29296 May 21 '13 at 13:16
    
user29296 is correct - it is the max-width in your CSS causing this now we've seen the site. –  zigojacko May 21 '13 at 14:37
    
how would I change that? I don't think I have access to the CSS. Is it possible for me to include overriding css on my page? –  Greg May 22 '13 at 15:28
    
You will have access to the CSS, it's part of your Wordpress theme. You'll need FTP access to your WP install (you'd need to contact your web host if you don't). Unless the installer has applied read/write access to the theme's files, and then you'd be able to edit the CSS from the Appearance > Editor menu. –  zigojacko May 22 '13 at 16:22
up vote 0 down vote accepted

I figured it out. The hint from user29296 is what led me to this: I had to insert the image using CSS, not html. Check the page now: http://macaulay.cuny.edu/eportfolios/menatwork/test-page/

The code was this:

<style type="text/css">
#image
{
position:absolute;
width:947px !important;
height:947px;
background-image:url('http://macaulay.cuny.edu/eportfolios/menatwork/files/2013/05/test.jpg');
background-repeat:no-repeat;
}
</style>
<div id="image"></div>

Thanks for the replies!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.