Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using a plugin which allows for multiple TLD's with WordPress multi-site. (WordPress MU Domain Mapping) No idea if this is a conflicting issue or not. Doubtfut, but thought I would throw it out there.

Every now and then, when I visit the primary website which multi-site was installed on, I get redirected to a page: http://www.primarydomain.com/wp-signup.php?new=primarydomain.com

Displaying the following text in a yellow box:

Greetings Site Administrator! You are currently allowing “none” registrations. To change or disable registration go to your Options page.

and a string of text beneath that:

Registration has been disabled.

Although, I already added define('NOBLOGREDIRECT', 'http://www.primarydomain.com/'); to wp-config.php

Why is this happening?

share|improve this question
    
Solution: wordpress.stackexchange.com/a/36526/9579 –  Michael Ecklund May 20 '13 at 21:36
    
Wasn't this a problem of siteurl being different from the NOBLOGREDIRECT value? –  brasofilo Jul 17 '13 at 17:57
    
Nope, all sites were set as: "www.domain-name.com". The problem was none of the sites were redirecting non-www URLs to www URLs. If you accessed any of the site URLs without prefixing them with "www", then the site would redirect to the primary site's network registration page. My solution was to make sure that you have all non-www URLS redirecting to www URLs for all of your sites in the network. –  Michael Ecklund Jul 18 '13 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.