Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

it's about the website www.kindheitsorte.de.

When you do a Google search for "kindheitsorte.de" you get to see "kindheitsorte.de/" as the result - no custom site title or description at all. When you do a Google search for "kindheitsorte" you get "Informationen" as the site title (which is pretty weird because this title has never been added - you can't even see it in the website's source code.

The website is running on Wordpress 2.9.2 and makes use of the All in One SEO Pack 1.6.13. I have added a custom description for each page with the All in One SEO Pack since the Home page of the website does not contain any text that Goolge could be interested in.

What do I have to do in order to have Google display the right title and also the description I have added?

Thanks a lot, guys!

share|improve this question
add comment

migrated from webapps.stackexchange.com Feb 21 '11 at 20:58

This question came from our site for power users of web applications.

2 Answers

The problem had a very simple cause - the WP privacy settings were set to "hide blog" without me noticing, that's why the website did not get craweled well by Google.

share|improve this answer
add comment

I have a hunch that Google favors English webpage Titles. Try changing your title from

<title>Buchpräsentation | Kindheitsorte - Eine Zieglerkindheit an der Havel</title>

to Childhood places

Also, consider serving the visitor their language with this plugin.

share|improve this answer
    
This can't be the reason since the same problem occurs when using Google.de which should (and obviously doesn't) favor English language page titles. The website is serving a domestic audience only (it belongs to a book which is only available in German), so using the qtranslate plugin would not make much sense in this case. But thank you anyway! –  dkt91 Feb 15 '11 at 11:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.